CI 묻고 답하기

제목 ci4 설치관련 질문입니다.
카테고리 CI 4 관련
글쓴이 엘제이 작성시각 2023/02/08 20:26:32
댓글 : 1 추천 : 0 스크랩 : 0 조회수 : 2733   RSS

오늘 작업장에 프리랜서로 일을 하게 되었는데 면접때  CI3로 

작업한다는 얘기를 들었는데 맋항 보니간 CI4 더라고요

당혹감에 어쨋든 비트나미 APM 을 설치하였고 

CI4를 콤포저를 이용해서 설치하였습니다. 그런데 하다 안되서

아파치 documentg root 등 을 public 으로 수정하였고 php ini에서

intl 관련 주석도 해제하니 웰컴페이지가 잘 나왔습니다.

일단 개발소스 덮어친건 둘째치고... 생각해보니 

라라벨도 웹서버 설치 안해도 php artisan serve 로 구동이 가능하잖아요

CI4도 php spark serve 이고요.. 그럼 제가 웹서버를 설치를 괜히 한것인

지요?

 

그리고 개발 소스를 엎어쳤는데 혹시 CI 버전이 안맞으면 오류가 나오는지요? 

 

 다음글 예전 CI3에서 엑셀 다운로드를 적용했었습니다. (1)
 이전글 해결됨 system 폴더에서 오류가 있습니다. (2)

댓글

변종원(웅파) / 2023/02/09 11:20:30 / 추천 0

설치관련 질문이라고 되어 있는데 실제 내용은 버전 달라도 작동하냐와 spark 문의네요.

ci 2에서 3은 아주 조금(대소문자 정도) 수정해야 작동하고 3->4는 다른 프로그램이라고 생각하시면 됩니다.

spark는 개발용이구요. 실제 서비스하려면 아파치나 nginx 돌리셔야 합니다.