CI 묻고 답하기

제목 해결됨 system 폴더에서 오류가 있습니다.
카테고리 CI 2, 3
글쓴이 php하러왔습니다 작성시각 2023/02/01 20:15:38
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 3008   RSS

비주얼스튜디오코드로 작성하고 있었는데

확장툴에 php 관련 확장툴을 잔뜩 깔아뒀더니 문제가 있었나봅니다.

디버그나 관련된 내용들 모두 지우고 다시 하니 잘 됩니다. 

 

안녕하세요. 검색해도 모르겠고

버전 문제인거 같은데 해결방안을 몰라 질문하러 왔습니다.

 

오류 내용을 사진처럼 첨부합니다

컨트롤러에서 $this->load-> 을 사용하려고 하면 load 에서

Undefined property: CI_Controller::$loadPHP(PHP0416)

이런 오류가 있다고 하는데

 

xampp 는 5.6.40 버전

https://sourceforge.net/projects/xampp/files/XAMPP%20Windows/5.6.40/

을 다운받았습니다.

 

최신버전

https://sourceforge.net/projects/xampp/files/XAMPP%20Windows/8.2.0/

으로도 확인했는데 같은 오류가 있습니다.

 

이유가 무엇인지 알 수 있을까요?

=& 라고 되어있는 곳마다 같은 오류가 있습니다 

이 외에도 system 폴더 내에 빨간색 노란색이 잔뜩 생기는데 

 

제가 어떤 xampp 버전을 깔고 사용해야하는지 모르겠네요

ci3은 http://www.ciboard.co.kr/user_guide/kr/installation/downloads.html 에서

ci3.0.6 을 다운로드해서 확인했습니다.

그리고 깃허브에서 ci3.2.0 버전으로도 확인했는데 동일 현상이 있습니다.

 

ci3을 다운로드 받아서 문서보고 crud 구현을 해보고 싶은데 xmapp 어떤 버전을 다운받아서 사용하면

코딩을 해볼 수 있을까요?

 

버전 문제가 맞는지 아니면 다른 문제가 있어 사용을 못하는 건지

해결방법 아시는분 소중한 답변 부탁드립니다.

 다음글 ci4 설치관련 질문입니다. (1)
 이전글 Windows Server에 CodeIgniter4 설... (2)

댓글

한대승(불의회상) / 2023/02/01 20:18:09 / 추천 0
PHP 7.4로 시도해 보세요.
php하러왔습니다 / 2023/02/01 20:32:03 / 추천 0

감사합니다 7.4 로 확인하고 5.6 다시 확인했습니다.

VS코드에서 php 디버그 하는 확장툴 제거하니 문제 없이 잘되네요

php 관련 확장툴 모두 제거했습니다 ㅠ