CI 묻고 답하기

제목 CI2.0 을 PHP7에서 사용 가능할까요??
카테고리 일반
글쓴이 빠빠치킨 작성시각 2021/05/24 17:58:51
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 507   RSS

PHP5 쓰고있던거 PHP7로 올리는중인데

 

CI 2.0을 그대로 가져가도 될지 궁금합니다.(CI2.1.4)

 

안될 이유는 없을것같은데

 

혹시라도 관련되어 이슈사항이 있는지 궁금합니다.

 

항상 감사드립니다~^^

 다음글 비번 확인 후 개인정보 변경 로직에 대해 질문드립니당! (3)
 이전글 에러 발생시 메일 발송 (1)

댓글

한대승(불의회상) / 2021/05/25 09:24:08 / 추천 0

php7 버전(7.0, 7.1, 7.2, 7.4등) 에 따라 지원 중단된 함수와 확장(특히 mysql)이 문제될 수 있습니다.

배강민 / 2021/05/25 09:27:33 / 추천 0

포럼에서 사용중인 TapBBS는 2.2.1로 PHP5에서 개발 진행되었지만, 아무 문제없이 PHP7으로 이관했습니다.

한대승님 말씀처럼 본인이 구현한 MVC의 코드로 인해 문제가 될수는 있지만 프레임워크 자체는 문제없을겁니다.