CI 묻고 답하기

제목 include_path 에 관련된 질문 도와주십시옹 ㅠㅠ
카테고리 일반
글쓴이 댕이아빠 작성시각 2019/01/24 02:35:30
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 450   RSS

A PHP Error was encountered

Severity: Warning

Message: 

A PHP Error was encountered

Severity: Warning

Filename: views/Login_view.php

Line Number: 3

Backtrace:

File: /var/www/html/aaa/application/views/Login_view.phpLine: 3

Function: _error_handler

File: /var/www/html/aaa/application/views/Login_view.phpLine: 3

Function: include

File: /var/www/html/inc/controllers/login.inc.phpLine: 61Function: view

File: /var/www/html/aaa/index.phpLine: 315

Function: require_once

 

에러가나는 3번 라인은 이렇습니다.         include('login_view.inc.php');

 

 

cafe24에서 서버 호스팅을 하다가

이번에 aws ami 로 이동중에

httpd.conf 설정 및 php.ini 설정도 만지면서

에러로 몇일째 헤메고 있습니다. ㅠㅠ

php.ini의 include_path 부분을 동일한 조건으로 맞춰서 하는데 위같은 에러가 나오면서 안되네용 ㅠ

 

aaa

bbb

ccc

 

inc

 

 

aaa,bbb,ccc 유저에게 개별 codeigniter 를 설치 및 config.php 수정하고,

inc라는 유저를 추가하여 inc 폴더의 공용 파일을 활용,

php.ini의 include_path 를 활용 , include 하여 여러 동일 프로그램이 돌아가는 조건입니다.

inc의 내용을 업데이트하면 a,b,c 모두 업뎃이 되는 형태입니다.

aws 서버를 세팅하면서 php는 7.0을 설치했습니다. 

cafe24는 php 5.4 입니다.

 

이전 cafe24서버에는 잘 되었는데

aws로 이전하면서 위같은 에러가 나면서 안되네용 ㅠ

 

 

무엇이 잘못 되었는지 짚어주시면 감사하겠습니다 도와주십쇼 형님들!!

 

 다음글 비트나미에서 코드이그나이터 사용법 질문입니다. (3)
 이전글 csrf 갱신관련문의 (1)

댓글

변종원(웅파) / 2019/01/24 04:27:08 / 추천 0
모델이 숏태그로 시작하는지 보세요. 에러메세지로 구글에서 검색하시면 답나옵니다
ci버전, 숏태그, 모델명 등등
댕이아빠 / 2019/01/25 00:13:58 / 추천 0
감사합니다 ami 다시 설치하구 첨부터 하다 보니 어케 됐네요 ;; 왜 된건지 이해는 안되지만 ㅡ,.ㅡ;;