개발 Q&A

제목 ci-3.1.9버전에 PHP8.0 에서 에러
카테고리 PHP
글쓴이 이나중마에노 작성시각 2022/03/30 19:18:22
댓글 : 7 추천 : 0 스크랩 : 0 조회수 : 2078   RSS

안녕하세요 ci를 배우고있는데요 

제목에 있다시피 ci-3.1.9버전에 PHP8.0 에서 화면을 연결하면 아래와같은 에러들이 뜹니다

버전문제인건지 도저히 감이 안와서요 소스는 문제없는 소스입니다 다른곳에서 잘되고있는 거에요

 

 

태그 PHP8.0,ci3,erro
 다음글 ci3 에서 mysql8.0 에러입니다 (1)
 이전글 json curl 통신 중 해더를 붙이면 상대 서버에서... (6)

댓글

한대승(불의회상) / 2022/03/30 20:47:04 / 추천 0

php 8.0 부터는 기본값이 있는 매개변수 뒤에 필수 매개변수가 오는 경우 오류가 발생합니다.

<?php
function test($a = [], $b) {} // 오류

function test($a, $b) {}      // 정상
function test($a, $b = []) {} // 정상

소스 코드를 잘 살펴보세요.

이나중마에노 / 2022/03/30 22:35:23 / 추천 0
감사합니다 이런 차이가 있었네요 PHP7.2버전으로 낮추면 괜찮겟죠?
변종원(웅파) / 2022/03/31 09:20:35 / 추천 0
codeigniter 각 버전별 매뉴얼 또는 change log를 보시면 해당 버전에서 지원가능한 php 버전이 명시되어 있습니다.
한대승(불의회상) / 2022/03/31 09:46:50 / 추천 0
@이나중마에노 7.4.x 적용하셔도 됩니다.
이나중마에노 / 2022/03/31 15:53:05 / 추천 0

한가지만 더 물어보겠습니다 PHP7.2 버전으로 낮춰 세팅했는데 아래와같은 에러는 머가 문제일까요?

 

한대승(불의회상) / 2022/03/31 16:28:31 / 추천 0

mcrypt php extension이 설치되지 않았군요.

메시지에 나와 있네요.

이나중마에노 / 2022/04/07 00:49:54 / 추천 0

안녕하세요 항상 감사드리며 또 다른 문제가 생겼는데요

ci3.1.9 php7.2 인데 mysql 8.0.28-0ubuntu0.20.04.3 입니다 아래와같은 에러가 나는데 이번엔 디비 버전문제이겠죠?

5.5.65-MariaDB 이정도 버전이면 맞을까요?